Power failure St Catherines Hill
Incident Report for Juice Broadband
Resolved
Power to St Catherines Hill has been restored and service was not affected by this power problem.
Posted Jun 20, 2018 - 08:06 BST
Investigating
Our St Catherines hill site has lost mains power and is on battery backup. SSE are aware and investigating. Currently service is unaffected however is at risk depending on length of the power cut.
Posted Jun 20, 2018 - 06:17 BST