Airport central node power failure
Incident Report for Juice Broadband
Resolved
Power has been restored, no service impact from this issue.
Posted Jun 14, 2018 - 06:36 BST
Investigating
We have a power loss notification from our Bournemouth airport central node. The site is active running on battery backup. Investigations are underway
Posted Jun 13, 2018 - 23:08 BST