DSL customers connected to Winton exchange
Incident Report for Juice Broadband
Resolved
Supplier update confirms the issue has been resolved:
"Our engineers have identified the location of the issue and re-routed traffic over a resilient path to restore customers service."
Posted Oct 12, 2020 - 12:11 BST
Identified
We are seeing broadband issues with customers connected via xDSL to Winton exchange. Our suppliers are aware and the problem is under investigation. Please do not press the reset button on your router, this issue is within the suppliers network.
Posted Oct 12, 2020 - 10:22 BST
This incident affected: xDSL Broadband (ADSL, FTTC, EoFTTC, GEA).